nixfiles/hosts/backstage/configuration.nix

39 lines
854 B
Nix

{ inputs, config, lib, pkgs, ... }:
{
imports =
[
../../services/sshd
inputs.nixfiles-private.nixosModules.hosts.backstage
];
# Set your time zone.
time.timeZone = "Europe/Berlin";
# Select internationalisation properties.
# i18n.defaultLocale = "en_US.UTF-8";
# console = {
# font = "Lat2-Terminus16";
# keyMap = "us";
# useXkbConfig = true; # use xkb.options in tty.
# };
environment.systemPackages = with pkgs; [
vim
git
tmux
htop
pciutils
lshw
ethtool
usbutils
];
# Copy the NixOS configuration file and link it from the resulting system
# (/run/current-system/configuration.nix). This is useful in case you
# accidentally delete configuration.nix.
# system.copySystemConfiguration = true;
system.stateVersion = "24.11"; # Did you read the comment?
}