42 lines
847 B
Nix
42 lines
847 B
Nix
{ config, lib, pkgs, modulesPath, ... }:
|
|
|
|
{
|
|
imports =
|
|
[ (modulesPath + "/installer/scan/not-detected.nix")
|
|
];
|
|
|
|
fileSystems."/" =
|
|
{ device = "zpool/root";
|
|
fsType = "zfs";
|
|
};
|
|
|
|
fileSystems."/home" =
|
|
{ device = "zpool/home";
|
|
fsType = "zfs";
|
|
};
|
|
|
|
fileSystems."/nix" =
|
|
{ device = "zpool/nix";
|
|
fsType = "zfs";
|
|
};
|
|
|
|
fileSystems."/nix/store" =
|
|
{ device = "zpool/nix/store";
|
|
fsType = "zfs";
|
|
};
|
|
|
|
fileSystems."/boot/efi" =
|
|
{ device = "/dev/disk/by-uuid/4E32-FA6E";
|
|
fsType = "vfat";
|
|
options = [ "fmask=0022" "dmask=0022" ];
|
|
};
|
|
|
|
swapDevices = [
|
|
{
|
|
device = "/dev/mapper/backstage-swap";
|
|
}
|
|
];
|
|
|
|
nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
|
|
hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
|
|
}
|